How to Configure and Use NordVPN on EdgeRouter & Ubiquiti

You can use the OpenVPN protocol of NordVPN on EdgeRouter running on EdgeOS firmware version 2.0.9 and later to get complete VPN security on all of your connected devices. Here we've provided a complete guide on how to set up and use NordVPN on EdgeRouter and Ubiquiti. Have a look. 

Note

If you're using an older firmware version on your EdgeRouter, consider installing the updates from the official Ubiquiti website before following this guide.

1. First, visit the NordVPN website.

2. Then, click the Grab the Deal button and choose a subscription plan. 

3. Enter the required details now to complete your purchase.

4. Once done, wait for confirmation

5. As soon as your subscription gets activated, create a new .txt file 'nordvpnauth.txt' on your PC. 

6. Next, open it and enter your NordVPN service credentials, i.e., username and password, in separate lines. 

7. To obtain your NordVPN service credentials, visit your online account dashboard and check the Advanced Configuration tab. 

Nord Account Service Credentials

8. Now, click here to note the hostname of the VPN server in your preferred location. 

9. After that, click the Show available protocols option and download the configuration file for UDP.

NordVPN server hostname

10. Next, modify the .ovpn server configuration file as mentioned below- 

  • Change 'auth-user-pass' into
auth-user-pass /config/openvpn/nordvpnauth.txt
  • Add an additional line
route-nopull

11. Save the file next, and it should look like this- 

client
dev tun
proto udp
remote 5.180.62.90 1194
resolv-retry infinite
remote-random
nobind
tun-mtu 1500
tun-mtu-extra 32
mssfix 1450
persist-key
persist-tun
ping 15
ping-restart 0
ping-timer-rem
reneg-sec 0
comp-lzo no
remote-cert-tls server
auth-user-pass /config/openvpn/nordvpnauth.txt
route-nopull
verb 3
pull
fast-io
cipher AES-256-CBC
auth SHA512
<ca>
-----BEGIN CERTIFICATE-----
MIIFCjCCAvKgAwIBAgIBATANBgkqhkiG9w0BAQ0FADA5MQswCQYDVQQGEwJQQTEQ
MA4GA1UEChMHTm9yZFZQTjEYMBYGA1UEAxMPTm9yZFZQTiBSb290IENBMB4XDTE2
MDEwMTAwMDAwMFoXDTM1MTIzMTIzNTk1OVowOTELMAkGA1UEBhMCUEExEDAOBgNV
BAoTB05vcmRWUE4xGDAWBgNVBAMTD05vcmRWUE4gUm9vdCBDQTCCAiIwDQYJKoZI
hvcNAQEBBQADggIPADCCAgoCggIBAMkr/BYhyo0F2upsIMXwC6QvkZps3NN2/eQF
kfQIS1gql0aejsKsEnmY0Kaon8uZCTXPsRH1gQNgg5D2gixdd1mJUvV3dE3y9FJr
XMoDkXdCGBodvKJyU6lcfEVF6/UxHcbBguZK9UtRHS9eJYm3rpL/5huQMCppX7kU
eQ8dpCwd3iKITqwd1ZudDqsWaU0vqzC2H55IyaZ/5/TnCk31Q1UP6BksbbuRcwOV
skEDsm6YoWDnn/IIzGOYnFJRzQH5jTz3j1QBvRIuQuBuvUkfhx1FEwhwZigrcxXu
MP+QgM54kezgziJUaZcOM2zF3lvrwMvXDMfNeIoJABv9ljw969xQ8czQCU5lMVmA
37ltv5Ec9U5hZuwk/9QO1Z+d/r6Jx0mlurS8gnCAKJgwa3kyZw6e4FZ8mYL4vpRR
hPdvRTWCMJkeB4yBHyhxUmTRgJHm6YR3D6hcFAc9cQcTEl/I60tMdz33G6m0O42s
Qt/+AR3YCY/RusWVBJB/qNS94EtNtj8iaebCQW1jHAhvGmFILVR9lzD0EzWKHkvy
WEjmUVRgCDd6Ne3eFRNS73gdv/C3l5boYySeu4exkEYVxVRn8DhCxs0MnkMHWFK6
MyzXCCn+JnWFDYPfDKHvpff/kLDobtPBf+Lbch5wQy9quY27xaj0XwLyjOltpiST
LWae/Q4vAgMBAAGjHTAbMAwGA1UdEwQFMAMBAf8wCwYDVR0PBAQDAgEGMA0GCSqG
SIb3DQEBDQUAA4ICAQC9fUL2sZPxIN2mD32VeNySTgZlCEdVmlq471o/bDMP4B8g
nQesFRtXY2ZCjs50Jm73B2LViL9qlREmI6vE5IC8IsRBJSV4ce1WYxyXro5rmVg/
k6a10rlsbK/eg//GHoJxDdXDOokLUSnxt7gk3QKpX6eCdh67p0PuWm/7WUJQxH2S
DxsT9vB/iZriTIEe/ILoOQF0Aqp7AgNCcLcLAmbxXQkXYCCSB35Vp06u+eTWjG0/
pyS5V14stGtw+fA0DJp5ZJV4eqJ5LqxMlYvEZ/qKTEdoCeaXv2QEmN6dVqjDoTAo
k0t5u4YRXzEVCfXAC3ocplNdtCA72wjFJcSbfif4BSC8bDACTXtnPC7nD0VndZLp
+RiNLeiENhk0oTC+UVdSc+n2nJOzkCK0vYu0Ads4JGIB7g8IB3z2t9ICmsWrgnhd
NdcOe15BincrGA8avQ1cWXsfIKEjbrnEuEk9b5jel6NfHtPKoHc9mDpRdNPISeVa
wDBM1mJChneHt59Nh8Gah74+TM1jBsw4fhJPvoc7Atcg740JErb904mZfkIEmojC
VPhBHVQ9LHBAdM8qFI2kRK0IynOmAZhexlP/aT/kpEsEPyaZQlnBn3An1CRz8h0S
PApL8PytggYKeQmRhl499+6jLxcZ2IegLfqq41dzIjwHwTMplg+1pKIOVojpWA==
-----END CERTIFICATE-----
</ca>
key-direction 1
<tls-auth>
#
# 2048 bit OpenVPN static key
#
-----BEGIN OpenVPN Static key V1-----
e685bdaf659a25a200e2b9e39e51ff03
0fc72cf1ce07232bd8b2be5e6c670143
f51e937e670eee09d4f2ea5a6e4e6996
5db852c275351b86fc4ca892d78ae002
d6f70d029bd79c4d1c26cf14e9588033
cf639f8a74809f29f72b9d58f9b8f5fe
fc7938eade40e9fed6cb92184abb2cc1
0eb1a296df243b251df0643d53724cdb
5a92a1d6cb817804c4a9319b57d53be5
80815bcfcb2df55018cc83fc43bc7ff8
2d51f9b88364776ee9d12fc85cc7ea5b
9741c4f598c485316db066d52db4540e
212e1518a9bd4828219e24b20d88f598
a196c9de96012090e333519ae18d3509
9427e7b372d348d352dc4c85e18cd4b9
3f8a56ddb2e64eb67adfc9b337157ff4
-----END OpenVPN Static key V1-----
</tls-auth>

12. Access your EdgeMax router via SSH now, and UNIX-like device users enter the below command for that. 

ssh ubnt@routersIPaddress

13. Enter the username and password of your EdgeRouter next.

14. Windows users download this app and perform the below commands- 

EdgeRouter Log in
sudo -i
cd /config/
mkdir openvpn
chmod 770 openvpn

15. Next, Linux users must disconnect from SSH and copy the recently created file nordvpnauth.txt and downloaded .ovpn file and paste those into the /config/openvpn directory via SCP; it should look like below- 

scp nordvpnauth.txt ubnt@routersIPaddress:/config/openvpn
scp de978.nordvpn.com.udp1194.ovpn ubnt@routersIPaddress:/config/openvpn

16. And, if you're using Windows, upload these files via SFTP

17. The default port for SFTP is 22.

SFTP connection on Windows for EdgeRouter

18. Next, run the following commands for your router- 

configure
set interfaces openvpn vtun0 config-file /config/openvpn/de978.nordvpn.com.udp.ovpn
set interfaces openvpn vtun0 description 'OpenVPN VPN tunnel'
commit
set service nat rule 5000 description 'OpenVPN Clients'
set service nat rule 5000 log disable
set service nat rule 5000 outbound-interface vtun0
set service nat rule 5000 source address 192.168.1.0/24
set service nat rule 5000 type masquerade
commit
set protocols static table 1 interface-route 0.0.0.0/0 next-hop-interface vtun0
set firewall modify SOURCE_ROUTE rule 10 description 'traffic from 192.168.1.0/24 to vtun0'
set firewall modify SOURCE_ROUTE rule 10 source address 192.168.1.0/24
set firewall modify SOURCE_ROUTE rule 10 modify table 1
set interfaces ethernet eth1 firewall in modify SOURCE_ROUTE
commit
save
Note

The commands will vary depending on the filenames you've selected before.

19. Next, check the connection log by entering the below command-

run show log

20. Now, scroll down until you find Initialization Sequence Completed. 21. Once you get that, your VPN connection will be established successfully. 

21. If you want to disable a VPN, use the following commands:

configure
set interfaces openvpn vtun0 disable
commit
save

 22. To re-enable the VPN, use the below commands:

configure
delete interfaces openvpn vtun0 disable
commit
save

23. And, if you want to change a VPN server, you’ve to upload a new file to your router and use the below commands:

configure
set interfaces openvpn vtun0 config-file /config/openvpn/new_file.ovpn
commit
Save

That’s all! Now you know how to configure and use NordVPN on EdgeRouter and Ubiquiti. If you’ve further queries, drop us a comment through the below button. Thanks for reading!

Latest
How to Watch Interior Design Masters Season 4 Online from Anywhere
Fans of this reality show, which offers ambitious designers a chance to demonstrate their abilities and pursue their dreams of becoming professional...
How to Watch Rock The Block Season 4 Online: Stream the Renovation Series from Anywhere
Rock the Block, the smash hit home remodeling contest series, is back for its most fantastic season ever! The new six-episode season...
How to Watch Spring Baking Championship Season 9 Online: Stream the Cooking Competition from Anywhere
There’s no better way to welcome spring with some freshly baked goods, and that’s precisely how we’ll usher in the good weather...
For a better user experience we recommend using a more modern browser. We support the latest version of the following browsers: For a better user experience we recommend using the latest version of the following browsers: Chrome, Edge, Firefox, Safari