News

Apple’s iCloud App Receives a Fix for Windows 10 October Update

By Nitish Singh / November 28, 2018

The Windows 10 October Update (build 1809) led to a number of sync issues for the desktop iCloud app. Users were unhappy about being unable to sync their Shared Albums and other data due to a newly introduced bug. Apple has addressed the issue with the latest 7.8.1 update. Official release patch notes are not available which indicates that there are no new features that are included with the update.

The new update requires you to have access to Outlook 2007 or later, or an iCloud account for syncing your emails, contact data, and calendar. If you want to sync your bookmarks, you need to use at least Internet Explorer 10, Firefox 30, or Google Chrome 28. The update is available from the official Apple support website.

Despite users being infuriated with the previous update that broke sync, Apple had explicitly mentioned that the update was compatible on Windows 7 through the April 2018 update for Windows 10. Despite the tech giant revealing incompatibility issues with the update, many users may have missed the information and ran into issues for weeks. After users approached Microsoft with the issue, they pointed to the patch notes from the previous update which detailed the incompatibility issues. The support page has now been updated to reflect the new changes and users should no longer face any bugs.

After the update was released to fix the issues, Microsoft updated its support page to mention "Apple has released an updated version of iCloud for Windows (version 7.8.1) that resolves compatibility issues encountered when updating or syncing Shared Albums after updating to Windows 10, version 1809.” Users affected by the issue should update their app at the earliest to resolve them.

What do you think about the bug affecting the iCloud app for Windows 10? Let us know in the comments below. Come chat with TechNadu on Facebook and Twitter



For a better user experience we recommend using a more modern browser. We support the latest version of the following browsers: For a better user experience we recommend using the latest version of the following browsers: